Forum SSOFast
18 Juillet 2019 à 04:30:16 *
Nouvelles: Bienvenue sur le forum de SSOFast!
 
   Accueil   Aide Rechercher  
Pages: [1]   Bas de page
  Imprimer  
Auteur Fil de discussion: RedHat.com [OK]  (Lu 4579 fois)
Presse Puree
Administrateur
Membre Complet
*****
Messages: 150


Voir le profil Courriel
« le: 21 Août 2006 à 14:44:25 »

https://www.redhat.com/apps/support/index.html?asp_charset=ISO-8859-1

pareil pour :
https://rhn.redhat.com/rhn/Login.do
« Dernière édition: 21 Août 2006 à 21:45:05 par iop » Journalisée
iop
Administrateur
Membre Complet
*****
Messages: 223


Voir le profil Courriel
« Répondre #1 le: 21 Août 2006 à 17:22:25 »

Ben, tu viens de trouver un type de formulaire mal ecrit, ils n'ont pas specifié d' "action" dans le "form"!
Donc, j'ai modifié la détéction pour que par defaut il y ai un "action=url", comme ca si "action" est specifié, celui-ci sera remplacé sinon le "form" utilisera l'url du lien!

Par contre, pour le 2eme url ( https://rhn.redhat.com/rhn/Login.do ), j'ai rien fais et il trouve bien un formulaire chez moi! Roulement d'yeux

Pour voir ce que trouve la detection auto vous pouvez utiliser ce lien : http://www.ssofast.com/test_url.php
Clin d'oeil

Par contre, des fois j'ai le message comme quoi rien n'a etait trouvé alors qu'un formulaire a bien etait trouvé! Huh?
Je me demande si y'a pas des problemes de transfert de données des fois!
Comme la detection est faite a partir d'une autre page, je pense que des fois la verification de la presence du formulaire est plus rapide que le stockage de ce formulaire!

Je sais, c'est pas claire :

Page 1 (SSOFast) lance Page 2 (auto_detect)
un fois la Page 2 (auto_detect) fini, celle-ci envoie le formulaire au serveur et grace a un "onload" la Page 1 (SSOFast) sait que c'est finit et demande le formulaire au serveur!
Mais apparement, des fois la demande de la Page 1 (SSOFast) est plus rapide que l'envoie de la Page 2 (auto_detect)!

J'vais mettre un ptite temporisation avant la demande! Très souriant

Sinon, les vacances sont déjà fini?!!! C'etait bien la corse?!
« Dernière édition: 21 Août 2006 à 17:32:33 par iop » Journalisée
Presse Puree
Administrateur
Membre Complet
*****
Messages: 150


Voir le profil Courriel
« Répondre #2 le: 28 Septembre 2006 à 12:26:28 »

Putain, je viens de comprendre pourquoi les sites de ma boite ne marchent pas...
En fait l'accés en restraint par Ip pour plus de sécurité et du coup le serveur qui heberge SSOFast n'y a pas accés ....

Mais comme si tu viens pas de la bonne Ip, y'a une redirection vers une autre page qui elle aussi a un formulaire, tu detectes bien un formulaire, mais qui pour le coup ne marche pas du tout....

Faudrait pouvoir changer le formulaire a la main pour le faire marcher.... (Quoi que je pourrais le faire directement dans la BD...)
Journalisée
iop
Administrateur
Membre Complet
*****
Messages: 223


Voir le profil Courriel
« Répondre #3 le: 28 Septembre 2006 à 13:37:47 »

J'ai pas bien compris ce qui se passe, mais l'essentiel c'est que toi oui... Tire la langue

Effectivement, pour l'instant, le seul moyen de modifier un formulaire à la main et de modifier la base de donnée...

Faut que je mette a bosser sur les options des admins... Roulement d'yeux
Journalisée
Pages: [1]   Haut de page
  Imprimer  
 
Aller à:  

Propulsé par MySQL Propulsé par PHP Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media XHTML 1.0 Transitionnel valide ! CSS valide !
Page générée en 0.06 secondes avec 17 requêtes.